Installer Wine sur Ubuntu pour les versions LTS

Wine est encore indispensable pour les jeux sous Ubuntu, même en 2018 ;)

Mais la version présente dans les dépôts Ubuntu (particulièrement pour les versions LTS) est très largement dépassée.

Il faut donc privilégier le dépôt officiel de Wine HQ. Voici la marche à suivre pour installer la version de développement.

Installation

Tout d’abord débarrassez-vous des précédentes versions de Wine que vous pouvez avoir et qui engendrerait des conflits. Prenez le temps de vérifier les paquets qui vont être supprimés avant de dire OUI ;)

playonlinux wine wine-gecko2.21 wine-mono0.0.8 wine1.6 wine1.6-amd64 wine1.6-i386:i386 winetricks

Vous pouvez également avoir envie de supprimer tous les fichiers générés par ces précédentes versions :

rm -rf .wine/ .PlayOnLinux/ .winetricks/ .cache/winetricks/

On ajoute ensuite le dépôt de Wine HQ et on installe winehq-devel :

wget -nc https://dl.winehq.org/wine-builds/winehq.key
sudo apt-key add winehq.key
sudo apt-add-repository https://dl.winehq.org/wine-builds/ubuntu/
sudo apt-get update
sudo apt-get install --install-recommends winehq-devel

On a également besoin d’installer Winetricks, qui est bien pratique pour contourner les éventuels problèmes :

wget https://raw.githubusercontent.com/Winetricks/winetricks/master/src/winetricks
chmod +x winetricks
sudo mv winetricks /usr/local/bin

Vous pouvez maintenant vérifier votre installation :

wine-3.17
20180815-next - sha256sum: 05f91c88de59e2ab9fc95012226d49e3bbe30dcd7c1a32370be5dff84b8349db

Mise à jour

Pour Wine, la mise à jour se fera automatiquement via les paquets APT.

Pour Winetricks, il suffit de lancer :

------------------------------------------------------
Update finished! The current version is [...]. Use 'winetricks --update-rollback' to return to the previous version.
------------------------------------------------------

Retour à une version précédente

Pour Wine, si une mise à jour des paquets APT venait à « casser » votre jeu, vous pouvez toujours revenir à une version précédente qui fonctionnait.

Pour cela, on précise la version sur l’ensemble des paquets concernés :

Les paquets suivants seront mis à une VERSION INFÉRIEURE :
  wine-devel wine-devel-amd64 wine-devel-i386:i386 winehq-devel

Et voilà le tour est joué !

Si vous voulez retrouver la liste des paquets qui sont concernés sur votre Ubuntu, voici mon astuce :

ii  wine-devel                                 3.17.0~xenial                                     amd64        WINE Is Not An Emulator - runs MS Windows programs
ii  wine-devel-amd64                           3.17.0~xenial                                     amd64        WINE Is Not An Emulator - runs MS Windows programs
ii  wine-devel-i386:i386                       3.17.0~xenial                                     i386         WINE Is Not An Emulator - runs MS Windows programs
ii  winehq-devel                               3.17.0~xenial                                     amd64        WINE Is Not An Emulator - runs MS Windows programs

8 réflexions au sujet de « Installer Wine sur Ubuntu pour les versions LTS »

  1. J’obtiens ce genre de message sous Ubuntu 18.04 en procédant ainsi :
    E: Le dépôt https://dl.winehq.org/wine-builds/ubuntu bionic Release n’a pas de fichier Release.
    N: Les mises à jour depuis un tel dépôt ne peuvent s’effectuer de manière sécurisée, et sont donc désactivées par défaut
    N: Voir les pages de manuel d’apt-secure(8) pour la création des dépôts et les détails de configuration d’un utilisateur.
    Bon…

  2. Bonjour ! Chapeau pour cette installation de Wine ! J’avais tout essayé, sans succès… Là, c’est du velours.
    Je suis un « semi-débutant » et j’ai apprécié la clarté de vos explications. Un grand merci !

  3. Bonjour, comment effectuer une installation proprement à partir des paquets officiels ?

    Quelques notes mais il me manque des étapes car pour le moment, wine application.exe n’est pas reconnu comme une commande debian.

  4. Merci pour votre tuto pas à pas super.
    J’utilise linux mint tessa.
    Dans synaptics,j’ai trouvé 3 paquets winehq: 1.devel 2.stable 3.staging;
    Prudent (trop ?) je n’ai installé que « stable » ,puis j’ai lancé avec wine cfg, Au cours de la configuration, ilm’a été proposé de télécharger et installer mono et gefko j’ai répondu oui.
    Comment le lancer alors que playonlinux en version4.3.4 me dit qu »elle ne prend pas en charge wine hq?

    Merci pourlaréponse

    • Hello, comme indiqué ici on utilise « winehq-devel » qui te donne « wine ». D’autre part, je n’utilise plus du tout POL, c’est bien mieux de passer en direct ;)

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *